Image Image Image Image Image Image Image Image Image Image

鸿毛21 - 生活、新知、感悟! | 2020/04/06

Scroll to top

Top

chrome

[技巧]Chrome扩展程序manifest_version清单文件

2012/12/02 |
无聊之余弄了个Chrome小拓展自用,也就是开发chrome小应用时碰到的小问题。但是在导出打包成.crx文件时居然提示:
“The 'manifest_version' key must be present and set to 2 (without quotes)”
错误,只生成了一个密钥文件,郁闷之余,经过一番查找,原来我的参考资料太古老了,"version":"1.0",清单文件已经不支持最新的 Chrome 18.0版本了,

“清单文件版本1:"version":"1.0"
在Chrome 18以前既可以明确地指定 版本1 ,也可以完全省略该属性。”
在Chrome 18及更高版本中,开发人员应该指定 ‘manifest_version’: 2 :
{
...,
"manifest_version": 2,
...
}

既然如此,修改完毕,成功打包.CRX文件,因为是小白,所以喜悦心情……

 

版本1与版本2之间的改变

内容安全策略默认情况下设置为 “script-src ‘self’; object-src ‘self’” Read More

Copyright © 2002-2016 鸿毛21 OK 鲁ICP备13001069号